Layer Intensity Control via DMX

Post Reply
Max X
Posts: 3
Joined: Wed Oct 18, 2023 12:39 pm

Layer Intensity Control via DMX

Post by Max X »

Hi,

Is it possible to control a single layer opacity with DMX? There is some script/macro to do it?
Schulze
Support
Support
Posts: 310
Joined: Fri Mar 22, 2019 4:21 pm
Contact:

Re: Layer Intensity Control via DMX

Post by Schulze »

Hi Max X,

Welcome to the MADRIX Forum!

Yes, this is possible and you don't need a macro to do it. You will find the function in the DMX-IN Remote Editor under Deck A / Deck B > Storage Place > Layer > Opacity > Layer

Here you can learn how to create a custom DMX-IN configuration / map:
https://help.madrix.com/tutorials/m5/HT ... x-in_.html
https://help.madrix.com/m5/html/madrix/ ... ditor.html

I hope this helps you!
Max X
Posts: 3
Joined: Wed Oct 18, 2023 12:39 pm

Re: Layer Intensity Control via DMX

Post by Max X »

Thank you Schulze,

It works perfectly. Now I have a little problem, when I’m creating a custom DMX patch into Madrix, it can’t be load automatically when I restart Madrix. Even if I save it with specific name and save the setup, this user patch does not load automatically but I need to load it by myself everytime…am I doing something wrong?

Thank you
Schulze
Support
Support
Posts: 310
Joined: Fri Mar 22, 2019 4:21 pm
Contact:

Re: Layer Intensity Control via DMX

Post by Schulze »

Hi Max X,

Please double check if all checkboxes are enabled in the "Open Setup Options", when loading the setup.
The DMX remote configuration as well as the Patch are part of the setup.
Attachments
Open_Setup_Options.png
Open_Setup_Options.png (17.33 KiB) Viewed 1845 times
Max X
Posts: 3
Joined: Wed Oct 18, 2023 12:39 pm

Re: Layer Intensity Control via DMX

Post by Max X »

Hi Schulze,

Yes, I load the setup normally (all boxes included), but almost everytime my custom personality just doesn’t load and everytime I need to reload this personality by myself (choose DMX IN device, check “remote” box in DMX IN tab ecc)

Also, when I’m using 2 layers, the second layer’s opacity is under DMX remote control (with SCE Fill Solid effect, effect option is set to Opacity Action -> RESTART), the first layer did’t play (it freezed) until I touch a second layer’s opacity…when I just touch this slider (with mouse or with dmx console) the first layer starts to play like it should. This happens only when I use Fill Solid with Effect Options enabled.

I’m using Madrix 5.5e version. I will try to update the version and will let you know if this issue persists…
Post Reply